8.x

Drupal 8 Soucis PHP

Bonjour,

J'ai fait une installation complète et automatique chez LWS.fr (auto instal). Je n'ai que des problèmes qui pour moi sont liés mais je n'en trouve pas la cause.

A la fin je vous copie le tableau de bord mais les problèmes sont multiples.

Impossible de toucher le theme de base, bartik, un seul changement de couleur et le site se retrouve blanc mais en respecant les blocs (apparement) impossible également de changé le style de couleur, je ne peux qu'appliquer le "par défault"

[Résolu] Afficher les commentaires par ordre décroissant (le plus récent en premier)

Bonjour à tous,

Voilà, je suis sur Drupal 8, je viens de mettre en place les commentaires. Tout fonctionne bien mais les commentaires sont triés du plus ancien au plus récent et je voudrais l'inverse. Je n'arrive pas à trouver où modifier ça. J'ai cherché dans les types de commentaires, dans les vues (mais aucune vue ne sert à ça), dans les templates.

Merci par avance,

Cécile

Mise à jour effectuée mais non détectée par Drupal

Bonjour,

Un petit coup de composer update drupal/core --with-dependencies donne "Nothing to install or update".

Quand je vais voir les "Mises à jour disponibles", ça donne :
"Drupal core 8.6.1 Mise à jour de sécurité nécessaire !

Version recommandée : 8.6.7 (2019-Jan-17) "

J'ai même essayé de forcer la 8.6.7 dans composer.json mais même résultat.

Views : contextual filter overide title me donne l'id au lieu du nom de l'entité

Bonjour,

J'ai une entité Formation et une autre Sujet. Il peut y avoir plusieurs formations qui traitent d'un même sujet.

Dans l'entité Formation, j'ai un champ "Reference>Content" qui lie à Sujet.

En souhaitant faire une vue avec contexte, je n'arrive pas à remplacer le titre par le Sujet->tilte, cela me donne toujours l'id (sujet->id).

Filtrer les commentaires

Bonjour à tous,

Je bloque sur la mise en place de mes commentaires.

J'ai créé un type de contenu qui accepte les commentaires. Je lui ai donc rajouté un champ de type commentaire. Dans mon article, ça rajoute donc la possibilité de commenter et au dessus la liste des commentaires apparaît mais avec le titre tronqué. Je cherche à afficher le commentaire en entier mais n'y parviens pas.

Liens mort en local

Bonjour, j'ai une question de newbie.
En sauvegardant mon site en ligne (sous Drupal 8) et en voulant travailler en local (sous wampserver), je me rends compte que plusieurs liens sont morts. Pas étonnant, le nom du site disparait !

Par exemple, sur mon site en ligne, j'ai un lien du type "www.monsite.fr/liens1".
Or sous wamp, j'ai alors "localhost/liens" à la place de "localhost/monsite/liens1".

Quelle manipulation doit-je faire sous wamp pour régler le problème ?
Merci de vos réponse.

Problèmes lors d'envoi de 2 mails

Bonjour,

j'utilise dans un module spécifique l'envoie d'un mail de confirmation d'une action faite par l'internaute en utilisant dans x.module l'appel (mailManager->mail...) et le hook_mail.

Tout se passe bien pour le premier appel mail.
Mais quand je veux faire une copie à l'administrateur, sans passer par le BCC pour personnaliser l'objet et ajouter une phrase dans le message, il ne m'envoie pas le second mail. Et en plus pas d'erreur après l'appel à " $mailManager->mail". C'est une adresse gmail, dans laquelle je reçois tous les messages du site.

Migration d'un site développé en local vers un hébergeur externe

Bonjour à tous,

Je tente désespérément de migrer un site Drupal8 développé en local vers un hébergeur externe sans réussite.

J'écume le net depuis deux jours, j'ai trouvé un tas de choses concernant des configs via htaccess, des modifications à faire dans la base de données pour modifier les références aux chemins locaux, mais je ne suis encore parvenu à rien.

Installation de Drupal 8 sur WAMP 3.1.4 et module Search API/SolR

Bonjour,

Je viens d'installer Drupal 8.6.4 sur WAMP 3.1.4. Tout s'est bien passé.
J'ai installé sans problème le module Search API 8.x-1.11 via admin/modules > Installer un nouveau module. C'est OK.

Mais quand je veux installer Search API SolR Search 8.x-2.3 il y a ce message "Solr search requires the solarium/solarium library."

J'ai fait une recherche où il est question d'installer les modules via Composer. Mais là je suis dépassé.

Qu'en pensez-vous ? Pourquoi le message ? Est-il encoure possible d'installer les modules comme je l'ai fait ?

Pages