8.x

Installation de Drupal 8 sur WAMP 3.1.4 et module Search API/SolR

Bonjour,

Je viens d'installer Drupal 8.6.4 sur WAMP 3.1.4. Tout s'est bien passé.
J'ai installé sans problème le module Search API 8.x-1.11 via admin/modules > Installer un nouveau module. C'est OK.

Mais quand je veux installer Search API SolR Search 8.x-2.3 il y a ce message "Solr search requires the solarium/solarium library."

J'ai fait une recherche où il est question d'installer les modules via Composer. Mais là je suis dépassé.

Qu'en pensez-vous ? Pourquoi le message ? Est-il encoure possible d'installer les modules comme je l'ai fait ?

Dossier admin

Bonjour;

Je reposte ma demande d'hier dans un nouveau fil (et non en réponse dans un ancien) en espérant avoir plus de succès. :-D

Donc, j'ai installé la dernière version de Drupal en interne, pour voir, sur ma Mint 17; tout n'a pas été très simple, mais cela s'est pas trop mal passé a priori, j'ai accès à la page d'accueil.
Mais chacun des liens "se connecter" ou "contact" me renvoie une erreur 404; et je ne trouve aucun dossier "Admin"...

Une piste de solution?

Cordialement

[Résolu] Installation de thème

Bonjour , cela fais maintenant 2 - 3 jours que j'essaie de me familiariser avec Drupal malheureusement je bloque sur un problème et je ne trouve pas la solution sur internet .

En effet lorsque je procède a l'installation d'un thème en plaçant le fichier dans le dossier ''thème'' de mon site , et que par la suite je définie ce thème par défaut directement depuis Drupal , le thème ne s'affiche pas correctement voir pas du tout même si il vient bousculé les blocs initiaux .

Problème de répertoire et 1&1

Salut à tous :)

Je viens vers vous pour avoir des conseils pour bien installer drupal et les thèmes je m'explique :

J'ai acheté un domaine 1&1 qui permet l'installation de drupal "simplifiée" grace à "click&build" qui crée dans mon répertoire /htpdoc/clickandbuilds/Drupal/MONSITE/(core,modules...) cela fonctionne bien,

Mais vaut mieux-t'il une installation manuelle ???

après traduction j'essaie d'installer un thème manuel dans core/themes/MONTHEME

le thème apparait dans apparence, je l'installe par défaut et voici le message qui apparait:

Drupal 8 - Classy paragraphs comment fonctionne t-il ?

Bonjour,

J'ai téléchargé Bootstrap Paragraphs afin de réaliser des layouts personnalisés.
J'arrive à créer un paragraph sans problème comme par exemple une image à gauche et un texte à droite.
Le souci est que quand je modifie un peu le CSS pour ajuster la position des éléments, le CSS s'applique sur toutes mes autres pages.. J'aimerais donc modifier uniquement le CSS d'une seule page. J'ai donc fait des recherche et suis tombé sur Classy Paragraphs. Seulement je ne comprends pas comment cette extension fonctionne...

Pouvez-vous me venir en aide ?

Accès impossible après copie de mon site surun autre serveur

Bonjour,
J'ai un site Drupal (version 8.4.2) en ligne. Et j'ai voulu faire une version en local pour les formations.

Pour cela, j'ai :
1. copié le dossier du site en ligne
2. sauvegardé la base de données en ligne
3. transféré le dossier sur le serveur local
4. crée une base de données en local et importé la base de données que j'ai sauvegardée
5. configuré le fichier setting.php pour rediriger la base de données

Le problème c'est que quand je veux accéder au site sur la machine en local je reçois une page où j'ai le message suivant :

Insérer "MA" vidéo avec CKEditor

Bonjour

Je souhaite insérer sous CKEditor ma propre vidéo. J'ai installé le module "video_embed_field-8.x-2.0.tar.gz" mais il ne veut que des URL externes.
Si je lui propose "\sites\default\files\users\user1/mavideo.mp4" (mp4 ou autre...) que j'ai transféré avec IMCE, j'obtiens l'erreur "CKEditor Could not find a video provider to handle the given URL."

J'ai testé le module Video qui me donne la même erreur

Y a-il une solution ?

Cordialement
Jean-Jacques

Pb des urls clean à l'installation

Bonjour,
Je jette l’éponge pour l’install en local de Drupal 8 sur windows ou linux à cause des « urls clean ».
Pour développer je suis obligé d’installer sur mon hébergeur et utiliser mon client FTP. Dommage j’ai épluché toutes les docs ubuntu depuis une semaine et à chaque fois il y a un os et chez windows n'en parlons pas!
En fait, la page d'accueil de Drupal se charge mais pas les autres!
J'obtiens le message:

Site local et site distant - Résolu

Bonjour

Je développe un site en local, en drupal 8, sous wamp64-3.1.3
Le site distant est chez OVH

J'avais l'habitude avec Drupal 6, de simplement modifier le "settings.php" avec les bons renseignements pour la base de données. Ainsi, le site distant fonctionnait sous Wamp et le site sous Wamp fonctionnait en distant.

Avec Drupal 8 et Wamp64-3.1.3 cela ne va pas.. j'obtiens
«
The website encountered an unexpected error. Please try again later.
»
C'est comme si il ne trouvait pas la base de données ou autre chose !

Pages