7.x

Database 4 byte UTF-8 support

Bonjour à tous,

j'ai un problème que je n'arrive pas à résoudre depuis quelques jours,

j'ai effectuer une mise à jour de drupal en version 7.50 depuis cette mise à jour, il me dis d'activer Database 4 byte UTF-8 support pour finir la mise à jour de la base de donnée donc j'ai suivis le tuto officiel de drupal pour l'activé sur le liens suivant : https://www.drupal.org/node/2754539.

parser un fichier xls

Bonjour, je suis actuellement sur un projet et j'ai besoin d'ajouter une fonction d'import d'un fichier .xls/.xlsx.
J'ai déjà crée l'interface d'upload, le fichier se retrouve sur le serveur, cependant j'aimerais parser le fichier pour pouvoir récupérer son contenu (soit pour l'envoyer vers une base de données, soit en faire un fichier .csv, ou autre.)
J'ai trouvé sur le net pas mal de solutions, la plupart du temps c'était l'utilisation d'un module "Feeds".

Filtrer une vue par un menu

Bonjour,
J'ai le menu suivant : (Formation bureautique, Formation informatique, Formation métier).
J'ai créer un contenu de type formation.
Je veux que le menu soit le filtre pour ma vue qui contient toutes les formations que j'ai créé.
Est ce que quelqu'un peut me dire si c'est faisable, et si oui comment le faire.
Merci d'avance.

Ecrire un article Planète sur drupal.fr

Bonjour,
je tente de poster un article Planète sur la traduction en de la documentation du module Features, pour lequel l'auteur est bien entendu requis, mais, au moment d'enregistrer, quelque soit le nom et même avec l'UID, il m'est indiqué soit "Auteur : nous n'avons pas trouvé d'utilisateur valide pour ce nom."
J'ai les rôles "adhérent" et "node administrateurs", mais peut être ne sont ils as suffisant pour créer ce type de contenu.
Du coup, j'ai créer une page de documentation, mais j'aimerai bien connaître le fin mot.
Merci

Deprecated function : preg_replace():

Bonjour toutes et tous,

Je vous sollicite votre aide, j'ai un message d'erreur quand j'active le diaporama (page et ou bloc) dans views
Ma version de views 7.x-1.0-beta1

Avez-vous une idée pour résoudre ce message ? (voir plus bas)
Sinon, j'avais pensé changer de version de views.

Merci

Faire cohabiter Drush 9.x et Drush 8.x pour des sites D8 et D7

Salut,

Sur un nouveau serveur, je n'ai pas de souci à administrer des Drupal 8 avec Composer et Drush installé en dépendance. J'ai également installé Drush Launcher ( https://github.com/drush-ops/drush-launcher ) pour avoir Drush toujours à la portée de la main.

Sur ce même serveur, je cherche à déplacer, d'un serveur à un autre, un Drupal 7 (qui n'a pas été installé via Composer, qui date donc d'il y a 5 ans) mais je n'arrive pas à faire cohabiter Drush v 8.1.6 avec Drush Launcher.

Demande de conseil pour choisir un thème drupal 7

Bonjour, je suis à la recherche de conseils pour choisir un nouveau thème pour mon blog Drupal7.
Mon site a plus de 2500 pages référencées et aujourd’hui mon thème est Premium Responsive.
Mon blog fonctionne parfaitement bien sauf que les visiteurs qui utilisent leur smartphone ne peuvent pas zoomer sur les pages et les images (avec les doigts).
Voila je suis à la recherche de conseil pour optimiser mon site pour un affichage 360x640 par défaut (smartphone)

[Résolu] Drush Error needs a higher bootstrap level

Bonjour,

Sur mon site Drupal 7.58 je n'arrive pas à faire certaines commandes DRUSH (version 5.9)

Dans l'urgence j'ai fait les mises à jour à la main parce que Drush ne voulait rien savoir

Si je lance Drush default pm-update :

Command pm-enable needs a higher bootstrap level to run - you will need to invoke drush from a [error]
more functional Drupal environment to run this command.

The drush command 'en update' could not be executed. [error]

Pages