Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Difficulté lors de l'installation de FCKeditor

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,
Je viens d'essayer d'installer le FCKeditor comme éditeur de texte mais j'ai un grand blanc qui s'affiche à la place du bloc de texte, sans l'éditeur. En bas de bloc, j'ai le message suivant :
"The ID for excluding or including this element is: edit-body - the path is: node/add/page"
Meme message avec un autre navigateur, un autre thème,...
Avez-vous une idée de solution ?

Merci par avance.

Version de Drupal : 

Je te conseille même de mettre l'input format par défaut du site en "Full HTML" directement, ça sera plus agréable à l'usage.

Si jamais j'ai rédigé une doc fr sur FCK vu comment ça m'avait trop embêté de trouver les infos :)

FCK Editor

  • aller dans «Administrer › Configuration du site › FCKeditor»
  • cliquer sur modifier le profile «Default»
  • développer «Visibility settings»
  • sélectionner «Use inclusion or exclusion mode» : «include»
  • saisir dans «Fields to exclude/include» : edit-body

Ça dit à FCKeditor de s'occuper de ce champ, sinon il ne se charge pas.

[edit] je parle de FCKeditor 6.x-1.4, il semble que sur la version 6.x-2.1 "Fields" et "Paths" soient regroupés et que la syntaxe soit plutôt *.edit-body (étoile et point devant)