Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Google map

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Un nouvel fois bonjour,

Je cherche à mettre une carte dans un site internet, et je n'y arrive pas. J'ai suivi le tuto ci, la carte ne s'affiche pas. Je ne comprends pas ça ne fonctionne pas. .

Je cherche juste à afficher une carte comme sur ce site en pied de page. Sans drupal j'y arrive, avec je galère un max !

Quelqu'un peut me donner une solution pour faire ma carte ?

Fichier attachéTaille
Icône image parametregooglemap.png104.77 Ko

vu le nombre de réponse pour mon problème je ne me suis pas pris la tête, enfin si pour trouvé une réponse sur internet mais rien..donc j'ai juste rajouté une importation basique de googlemap..

Je t'explique ton problème. Moi aussi je débute et je suis tombé sur ce même problème. En fait GMAP utile les champs longitude et latitude de location. Or location ne remplis pas les champ longitude et latitude à partir de l'adresse donnée... ce qui est débile. je te recommande d'utiliser le module "Geolocation" (ici) et dans ta vue tu ajoute les champ longitude et latitude et dans "settings" de GMap tu change le champ "Location.module" par "Geolocation.module" tu verra il va te demander de sélectionner le champ longitude que tu à ajouté et latitude.

Ou alors

Tu va dans les paramètres de Location et tu cherche quelque chose du genre "set latitude / longitude with google map" et tu coche. Après lors de ton remplissage des informations tu aura une carte où tu devra cliquer pour définir la longitude et latitude mais c'est vachement moins bien fichu que "Geolocation" ;)

Merci de ta réponse,

Je n'ai pas tout piger de ta réponse.. . J'ai bien installer Geolocation mais je n'ai pas la possibilité de rajouté des champs longitude et latitude dans les champs de ma vue.. Je ne trouve pas les settings de Location.. .

J'ai suivi le tuto, cartographie-rapide-avec-drupal, mais je bloque.. . J'ai créé une "vue/view" dans un bloc, de type "Map (Google API, via IPGV&M)" pour faire afficher ma carte dedans, j'ai rajouté le "champ/field" qui contient mes paramètres Geolocation de mon "type de contenu" créé auparavant et rien.. .

Je ne pige pas comment régler les paramètres de " Map (Google API, via IPGV&M) ", dans le tuto je ne pige pas ce que je dois reseigner.. Hors view ça marche mais je veux la mettre dans un bloc pas dans une page..

Si ça marche dans une page, tu peux créer un affichage de type bloc.

Et si c'est pour afficher juste un contenu, alors au pire tu peux créer une vue de type bloc, qui affiche juste le contenu que tu veux, même si c'est un peu "overkill".

Tu fais comment pour créer le type de contenu dans un bloc.. . Je sais "ajouter un bloc" mais je ne savais pas que l'on pouvait créer des types de contenus spécifiques dedans. . sauf avec view. .

Mon problème avec view c'est que je n'arrive pas à faire afficher la carte, j'ai suivi ton tuto mais rien n'apparait, je cale au niveau des réglages des paramètres .. Tu dois renseigner le "contenu:localisation" dans quel champ ?

J'ai les deux champs, le titre s'affiche, la carte non.

Lorsque je renseigne aucuns champs dans les "paramètres" du "format" "Map (Google API, via IPGV&M)", j'ai ce texte qui s'affiche au chargement de ma page. Pas de carte

None of the 1 result rows in view MapGarage (Block) had their ip_geoloc_latitude set. Therefore those rows could not be displayed as locations on the map. Are you using the correct field names?

Lorsque je renseigne le "contenu : Location" (champ GeoLocalisation créé dans un type de contenu) dans le champ "Grouping field Nr.1 " des "paramètres", j'ai ça comme texte qui s'affiche. Et toujours pas de carte.

None of the 1 result rows in view MapGarage (Block) had their set. Therefore those rows could not be displayed as locations on the map. Are you using the correct field names?

Je ne trouve vraiment pas mon erreur.

Je ne sais pas par quel hasard la carte c'est affichée ce matin.

Par contre j'ai beau changer le numéro de zoom avec un rafraichissement du cache, ça ne change pas. Je ne veux pas aussi le scroll de la souris sur la carte, je n'ai pas coché la case correspondante, le zoom scroll est pourtant présent? ? Quelqu'un peut m'éclairer.

D'ailleurs pour changer le hauteur du rendu de ma carte j'ai dû le mettre dans "Map style (CSS attributes)" des paramètres de mon format "Map (Google API, via IPGV&M) ". Dans mon champ cela ne marche pas, et dans le type de contenu non plus, les styles n'influence pas le style de base 300px. .

Je crois que j'ai trouvé, pas sûr que ce soit la bonne solution..

dans les paramètres de format "Map (Google API, via IPGV&M) ", dans la partie "Map centering options ", j'ai coché "Fixed center; see note below" et rajouté ça dans la zone "Map options " -> {"mapTypeId":"roadmap", "zoom":13, "centerLat":48.424367, "centerLng":-2.931743, "scrollwheel" :false}

Il y a 5 min, je viens de lire "Google Maps ne s'est pas chargé correctement sur cette page. Pour plus d'informations techniques sur cette erreur, veuillez consulter la console JavaScript." <-> js?sensor=false ?? d'ailleurs je ne sais même pas vraiment où il faut que je regarde pour trouver le message d'erreur js. .

ça marchait hier, aujourd'hui nan. . C'est une histoire de clé ? Je fais le site pour un ami.. Je n'ai pas envie de lier mon compte google à son site.. . Il y a une solution si c'est ça le problème ?

Lorsque je créai une nouvelle page.. j'ai droit à ce message sous votre page à été créé : Out of a total of 2 result rows in view MapGarage (Block), 1 rows did not have their field_localisation set and therefore could not be shown on the map. The first row that could not be located was row #2 (nid #8). You can improve execution efficiency by using the Views UI to add an "is not empty" filter for field_localisation.

je ne pige pas tout là.. Quelqu'un peut m'éclairer ?