Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Aide avec .htaccess:

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous,

étant débutant sur Drupal, je ne parviens pas à résoudre les problèmes liés au fichier .htaccess, voir capture d'écran.

D'avance, merci pour votre aide et excellente journée!

Fichier attachéTaille
Icône image capture_decran_2014-03-05_a_11.42.58.png108.45 Ko
Version de Drupal : 
Tags : 

Bonjour,

en allant sur les liens donnés dans le message d'erreur (https://drupal.org/SA-CORE-2013-003), tu trouvera le code a mettre dans ton fichier htaccess.

Pour drupal 7

# Turn off all options we don't need.
Options None
Options +FollowSymLinks

# Set the catch-all handler to prevent scripts from being executed.
SetHandler Drupal_Security_Do_Not_Remove_See_SA_2006_006
<Files *>
  # Override the handler again if we're run later in the evaluation list.
  SetHandler Drupal_Security_Do_Not_Remove_See_SA_2013_003
</Files>

# If we know how to do it safely, disable the PHP engine entirely.
<IfModule mod_php5.c>
  php_flag engine off
</IfModule>

tu copies colle ce code dans un nouveau fichier via un éditeur de texte, que tu renommes .htaccess par la suite, et il te suffit de le mettre dans les repertoires correspondant (sites/default/files & /tmp).

J'ai eu le même problème récemment et en suivant cette procédure, le problème est réglé.

Merci pour la réponse, ce code doit-il rajouté à la suite de l'existant ou, doit-il remplacer le tout?

De plus est-ce le même fichier .htaccess (et même contenu) dans les deux répertoires (sites/default/files et /tmp)?

D'avance, merci pour ton aide précieuse!

si tu as déjà des fichiers .htaccess dans chacun de ces répertoires, ajoutes le code au code déjà présent dans le fichier (en évitant les éventuels doublons). Si il n'y a pas déjà de fichiers .htaccess, alors oui, ce sera le même fichier dans chaque répertoire.

Attention, il y a une petite précision sur la page ou se trouve le code en question :

Additionally, the .htaccess of the temporary files directory and private files directory (if used) should include this command:

Deny from all

à ajouter en fonction

Salut et encore une fois merci pour ton aide, malgré les modifications, le message persiste toujours pour le répertoire /tmp...

Y'aurait-il un texte complet à copier-coller directement en lieu et place de celui d'origine?

Peut-être que je fais un truc qui ne convient pas :-( .

Il me semble que j'avais eu un soucis également avec le répertoire /tmp ; je ne suis pas sur d'avoir passé du temps à résoudre ça (et je n'ai pas l'accès à ce site sous la main pour vérifier) mais peut être est-ce un problème de chemin d'accès. Peut être que le répertoire /tmp auquel drupal fait référence n'est pas celui dans lequel tu mets le .htaccess