gmap et api key me font tourner en bourique...

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous,
Sur cette page :http://www.1nature2langues1reseau.eu/reseau
j'ai une vue avec une carte gmap.
Ma carte fonctionnait bien (avec des anciennes clés gmap) et là je découvre que ça ne marche plus et que j'ai un message :

Google has disabled use of the Maps API for this application. The provided key is not a valid Google API Key, or it is not authorized for the Google Maps Javascript API v2 on this site. If you are the owner of this application, you can learn about obtaining a valid key here: http://code.google.com/apis/maps/documentation/javascript/v2/introductio...

Je vais sur l'adresse indiquée,je prends une nouvelle clé "brower key" et je mets à jour mon module key de drupal que j'utilise car j'ai plusieurs url pour ce site.

Et bien ça marche toujours pas... Je ne comprends pas...
Dans le code source de la page, la clé semble être la bonne...
Je comprends encore moins car j'ai un autre site sous drupla avec une autre clé, et là tout fonctionne...

Où est-ce que j'ai raté quelque chose ? Parce que là je commence à devenir dingue...

Merci d'avance pour votre aide

Version de Drupal : 
Tags : 

Bon je suis désolé j'ai posté pour rien car entre temps ça fonctionne...
J'avais un problème avec les url différentes et j'attribuais directement des clés en fonction de $_SERVER['HTTP_HOST'] car le module key ne faisait pas son travail

Je n'avais pas changé toutes les clés pensant que ça n'empêcherait pas de fonctionner sur les bonnes url que je testais. A priori si (pourquoi ? Je n'ai pas compris). en changeant tout dans ce fichier, ça fonctionne bien
Désolé

Salut,

Je débute en voulant faire un site de covoiturage et j'ai le même problème que toi. J'ai réussi avec drupal 6 à faire fonctionner les cartes google mais cette fois ci j'ai le même message d'information que toi. Par contre je n'arrive pas à règler le problème. Je ne sais pas encore mettre le nez dans le code php des modules, c'est peut être là que ça coince. J'ai besoin de votre aide.

merci

A croire que la réussite est contagieuse lorsque l'on poste ici. En effet j'ai pu résoudre mon problème avec gmap et drupal 7. Il s'agissait pour moi d'installer le module keys et de lui faire associer la clef de l'api google map avec le nom du domaine.

J'ai un peu galéré car je travail sur une installation multisite mais en prenant soin de rentrer juste le nom du domaine, ça a résolu mes problème... heureusement d'autre m'attendent au tournant.

Merci