Vider la table watchdog automatiquement car OVH n'assure plus

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

OVH empêche le bon fonctionnement de mon site, c'est un fait. Il faut dire que j'ai énormément de tables, et tous les logs sont stockés dans la table watchdog. Malheureusement, il se trouve que le watchdog est un module coeur de drupal et je ne peux pas le désactiver.

Alors, il me faut trouver une autre solution, ou bien pour vider la table watchdog automatiquement et là, je me souhaite bon courage via mon offre OVHARNAQUE ou j'ai un accès à phpmyadmin et mon répertoire en ftp (même la ré-écriture d'url ne fonctionne pas).

A partir de là, je n'ai pas d'idée, si ce n'est changer d'offre OVH ? Mais qu'est-ce qui me garantie que le pb ne se reposerait pas.

Voilà Ze Soucy ! Je suis certain que le pb est lié à OVH car le site fonctionne parfaitement en local et sur AMEN (malheureusement mon client avait déjà son offre d'hébergement).

Merci pour une aide précieuse.

Version de Drupal : 

Je précise que j'ai une misérable offre mutualisé chez OVH et donc je n'ai pas accès au php.ini

Voici le type de message d'erreur

[code]Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 4414527 bytes) in /homez.134/emjqil/www/includes/database.mysql.inc on line 310[/code]

Merci, je ne connaissais pas cette option. Malheureusement j'étais déjà au minimum. Mais je n'ai pas l'impression d'avoir eu un cron bien configuré. Pouvez-vous m'indiquer comment automatiser le cron sous OVH ?

Merci d'avance.

Bonjour,

J'ai déjà rencontré le soucis sur OVH en mutualisé et j'ai désactivé le module Watchdog (sisi c'est possible :) ) qui porte le nom de Database logging dans la liste des modules.

Depuis, plus de soucis.

EDIT : La réecriture d'URL fonctionne correctement chez OVH.

Ca vire au drame... Je ne peux même plus accéder à ma page de modules tellement que ça rame. Du coup, il faudrait que je désactive le module à la mano.

Par contre, ce qui m'inquiète vraiment, c'est que j'ai vidé la table watchdog et la page de modules ne s'ouvrent pas...

Maudit OVH.