Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Modules non installés sous sites/all/modules

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

j'ai récupéré un site construit avec Drupal. Les modules ont été installés sous le dossier 'module' à la racine du site alors qu'il faut normalement les sous sites/all/modules.
Des mises à jour ont été effectuées. Certaines fonctionnalités de l'administration ne fonctionnent plus.

  • Quels sont les risques?
  • Est ce que je peux tranquillement continuer à faire les mises à jour requises (si l'admin le permet!) ou installer de nouveaux modules?
  • Est ce que je peux bêtement tenter de couper/coller les dossiers dans le bon répertoire?
  • Ou dois je recréer le site (drupal core + tous les modules existants) puis importer la base?

Merci pour vos retours d'expérience.

Version de Drupal : 

Je pense que tu vas devoir tester en dupliquant, si cela est possible, ton projet Drupal (répertoires + base de données) en local par exemple (sous Wamp/Xamp ou autre) et que ta duplication donc tu tentes de déplacer tes modules. Je te conseille de déplacer tous les modules mal situés et de bien vérifier ensuite que tous ces modules fonctionnent (formulaires de saisie).