Activer clean URL ?? .htaccess ?? httpd.conf ??

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjours à tous!

Voilà, je débute avec Drupal, et même avec l'informatique en général, et là je bute depuis 2 jours sur un problème. En effet, un amis a créé un site internet (www.gbradio.fr). Il m'a demandé de prendre la relève.

Or pour commencer à me plonger dans mon site, je souhaite d'abord l'utiliser en local, histoire de ne pas faire trop de bêtises sur le site en ligne. Après imporation des fichiers via mon FTP (filezilla), j'ai importer ma base de donnée sur phpmyadmin (je tourne sous wamp). Base de donnée gigantesque, obligé de passer par les commande windows -u root _p <nom_base... un peu casse tête déjà !

Une fois mes fichiers setting.php et config.inc.php modifier, je changes mes mots de passe et tout le tralala... Je lance Wamp, je rentre localhost/gbradio et... merveille !! la page d’accueil de mon site s'affiche à nickel.
Problème tout de même, lorsque je tente de naviguer sur le site, les pages sont introuvable. (erreur 404)...

Ayant essayer de comprendre, j'ai cru trouver ma réponse. Il faudrait aparemment activer clean URL dans Drupal?

J'ai aussi vu des solutions qui consistes à dé commenter la ligne :

LoadModule rewrite_module modules/mod_rewrite.so

en

LoadModule rewrite_module modules/mod_rewrite.so

dans le fichier httpd.conf de apache. Aucun résultats...

J'ai aussi vu une solution qui consisterai à modifier un fichier .htaccess... Imposible de mettre la main dessus...

En clair, je galère !

Si quelqu'un pourrait m'aider dans ma quête, je lui serait vraiment reconnaissant, ces deux derniers jours de recherches sans résultats m'ont explosés mon enthousiasme..

Merci d'avance.

Paul.

Version de Drupal : 
Tags : 

J’ai aussi vu une solution qui consisterai à modifier un fichier .htaccess… Imposible de mettre la main dessus…

???? .htacces est à la racine du site, vous devriez les trouver sans problemes (sous mac il faut afficher les fichiers cachés)

il contient un directive de redirect qui devrait régler le problème

En attendant d'avoir réglé le problème, tu peux désactiver le mode clean url en local, via :

http://tonsiteenlocal/?q=admin/settings/clean-urls

Sinon, (cf: http://drupal.org/node/15365) il faut modifier le fichier httpd.conf, pour faire le LoadModule (ce que tu a fait), et également ajouter la ligne

AllowOverride All

au niveau de la directory utilisée pour le site. Sinon apache n'utilise pas le fichier .htaccess (il doit y en avoir un à la racine du site drupal)

Merci à tous pour vos informations très précieuses !
Ce forum est une mine d'or, merci encore. Je vais continuer à suivre vos piste, je vous tiens au courant si je franchis cette nouvelle étape.

Cordialement, Paul.

Re- bonjour à tous ! bon voilà, j'ai bien avancé sur mon site, merci à vous deux ! Je vous transmet tout de même le dernier message que j'ai posté sur le forum... Si jamais l'un de vous deux à quelques minute à m'accorder, ce serait super.

Bonjours à tous !

Tout d’abord, un grand merci pour cette merveille qu’est Drupal, et toute cette documentatio est une véritable mine d’or ! Mais tout de même, je galère sur quelques point..

Alors voilà, étant encore novice dans l’utilisation de Drupal, je bute sur certains problèmes… J’ai repérer le module «audio» qui m’a l’air bien pratique ! Seulement voilà, après l’installation de audio, getid3, token, je me lance dans la configuration e mon module. Je vais dans «import setting audio» sur ma page d’administration, et là premier problème : On me demande d’entrer le «link path» pour l’importation.

Par défaut, Drupal met comme link : tmp/audio. Un message d’erreur m’avertit que ce répertoire n’existe pas.. Je navigue donc sur mon PC (précision, je travail en local…), et je vais dans www/monsite/sites/default/tmp et je créé un dossier «audio» dan lequel j’ajoute un fichier audio (fichier très léger, 1.2 M) donc pas de problème de taille avec php.ini. Alors je laisse le champ «link path» intacte avec tmp/audio.

Et là, le message d’erreur persiste et signe ! «le répertoire tmp/audio n’existe pas»… Alors, une solution me viens à l’esprit : modifier l’url de base dans setting.php ? Je me plante peu être complètement… En tout cas cette URL n’est pas définie (elle est en commentaire). Or il m’est désormais impossible de modifier le fichier setting.php…

J’ai beau l’ouvrir avec notepad++, impossible de modifier la mondre ligne !

Et si j’essaye d’importer un fichier directement, (en mode «bourrin») : C:\wamp\www\gbradio\sites\default\files\tmp\audio\00 - Police - Roxanne.mp3

sans configurer le module, j’obtient le message d’erreur suivant :

» warning : move_uploaded_file(/tmp/00_-police-roxanne.mp3) [function.move-uploaded-file] : failed to open stream : No such file or directory in C:\wamp\www\gbradio\includes\file.inc on line 615.
warning : move_uploaded_file() [function.move-uploaded-file] : Unable to move ‘C:\wamp\tmp\php8AB3.tmp’ to ‘/tmp/00-police-_roxanne.mp3’ in C:\wamp\www\gbradio\includes\file.inc on line 615.
Erreur dans le transfert de fichiers. Impossible de déplacer le fichier transféré. «

Pour info, la ligne 615 de file.inc est :

«if ( !move_uploaded_file($_FILES[‘files’][‘tmp_name’][$source], $file->filepath)) {
form_set_error($source, t(‘File upload error. Could not move uploaded file.’)) ;
watchdog(‘file’, ‘Upload error. Could not move uploaded file %file to destination %destination.’, array(‘%file’ => $file->filename, ‘%destination’ => $file->filepath)) ;
return 0 ; «

En bref, je galère ! Si quelqu’un pourrait donner un petit coup de pouce, je serait le plus heureux des drupaliens ! =) heeeeeelp !

Cordialement, Paul.

Désolé je ne connais pas le module audio

Avez vous vu ce thread ? My fix for /tmp/ issue ... ici : http://drupal.org/node/78104
apparemment c'est le problème que vous avez

souvent il faut donner l'url complete à drupal
pas seulement /tmp/audio, mas l'url absolue
apparemment il faut aller sur /modules/audio/getid3/demos/demo.browse.php pour la trouver