Message d'avertissement

The subscription service is currently unavailable. Please try again later.

better message pour anonyme

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous!

Pour rendre mes drupal_set_message plus jolie j'utilise Better_message qui bien quand on est authentifié. Par contre, rien ne s'affiche pour les anonymes...

Quelqu'un a-t-il une idée sur l'origine du problème?

Merci

Version de Drupal : 

Personne n'a une idée du pourquoi?

J'ai rerererevérifié les droits et c'est toujours le même problème. Si je décoche les droits pour anonyme, c'est le drupal_set_message de base de drupal qui s'affiche, sinon si je coche le droit, aucun message ne s'affiche... que faire??

Cela ne peut pas être la cause car dès que j'enlève le droit aux anonymes de voir les messages avec Better Messages, ce sont les messages de base de drupal (drupal_set_message) qui prennent le relais et ceux-ci marchent parfaitement...

Salut T-Mak,

Je viens d'installer Better Messages et après quelques réglages, tout fonctionne y compris pour les anonymes.

Voila comment j'ai procédé :

Après l'installation puis l'activation du module, je suis allé paramétrer "Droits d'accés". J'ai coché "access better messages" pour "utilisateurs anonymes" et "utilisateurs identifiés"

Ensuite dans les options de ce module, dans la section "Messages appearance" il est dit de choisir un skin et précise que si on désire le sien, il faut mettre les fichiers css et le dossier image dans un dossier appelé "skins" dans notre theme.
J'ai donc, pour tester le truc, copié le dossier skins situé dans le dossier du module pour le mettre dans celui de mon theme. J'ai également déclarer le fichier css dans mon_theme.info

Une fois que j'ai constaté le bon fonctionnement, j'ai renommé le fichier default.css du dossier skins en mon_theme_messages.css puis modifié mon fichier mon_theme.info, je suis retourné dans l'onglet "Messages appearance" des paramétres du module pour séléctionner le nouveau skins.

Cordialement,

Thib

J'ai fais la même chose que toi sauf pour la declaration dans le .info donc peut-être que le problème vient de là.

Je testerai cela demain et si ça ne marche pas je réinstallerai le module en suivant la même procédure que toi.

Merci pour ton retour.

Cordialement,

T-MaK