Mise à jour Drupal commerce KickStart

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous,

J'essaye désespérément de mettre à jour un site d'e-commerce d'un client.
Je suis novice en Drupal.

Voici les informations du site existants:
Drupal version: 7.18
Drush version: 8.1.10
Install profile: commerce_kickstart

J'ai vérifié avec Drush les mises à jour de sécurité:

drush up --security-only

Name                                           Installed Version  Proposed version  Message                  
Drupal                                         7.18               7.54              SECURITY UPDATE available
Views Bulk Operations (views_bulk_operations)  7.x-3.1            7.x-3.4           SECURITY UPDATE available
Address Field Tokens (addressfield_tokens)     7.x-1.3            7.x-1.5           SECURITY UPDATE available
Chaos tools (ctools)                           7.x-1.2            7.x-1.12          SECURITY UPDATE available
CKEditor (ckeditor)                            7.x-1.12           7.x-1.17          SECURITY UPDATE available
Commerce (commerce)                            7.x-1.4            7.x-1.13          SECURITY UPDATE available
Commerce Kickstart (commerce_kickstart)        7.x-2.0            7.x-2.45          SECURITY UPDATE available
Ogone (commerce_ogone)                         7.x-1.3            7.x-1.6           SECURITY UPDATE available
Context (context)                              7.x-3.0-beta6      7.x-3.7           SECURITY UPDATE available
Date (date)                                    7.x-2.6            7.x-2.10          SECURITY UPDATE available
Display Suite (ds)                             7.x-2.0            7.x-2.14          SECURITY UPDATE available
Entity API (entity)                            7.x-1.0-rc3        7.x-1.8           SECURITY UPDATE available
Entity Reference (entityreference)             7.x-1.0            7.x-1.2           SECURITY UPDATE available
Features (features)                            7.x-1.0            7.x-2.10          SECURITY UPDATE available
Fieldgroup (field_group)                       7.x-1.1            7.x-1.5           SECURITY UPDATE available
Media (media)                                  7.x-1.2            7.x-1.6           SECURITY UPDATE available
Google Analytics (google_analytics)            7.x-1.3            7.x-2.3           SECURITY UPDATE available
Internationalization (i18n)                    7.x-1.7+14-dev     7.x-1.15          SECURITY UPDATE available
Inline Entity Form (inline_entity_form)        7.x-1.0            7.x-1.8           SECURITY UPDATE available
jQuery Update (jquery_update)                  7.x-2.3            7.x-2.7           SECURITY UPDATE available
LoginToboggan (logintoboggan)                  7.x-1.3            7.x-1.5           SECURITY UPDATE available
MailChimp (mailchimp)                          7.x-2.10           7.x-4.8           SECURITY UPDATE available
Meta tags (metatag)                            7.x-1.0-beta5      7.x-1.21          SECURITY UPDATE available
Meta tags (quick) (metatags_quick)             7.x-2.7            7.x-2.9           SECURITY UPDATE available
Migrate (migrate)                              7.x-2.5            7.x-2.8           SECURITY UPDATE available
Mime Mail (mimemail)                           7.x-1.0-alpha2     7.x-1.0-beta4     SECURITY UPDATE available
OAuth (oauth)                                  7.x-3.0+18-dev     7.x-3.4           SECURITY UPDATE available
Services (services)                            7.x-3.3            7.x-3.19          SECURITY UPDATE available
Rules (rules)                                  7.x-2.2            7.x-2.9           SECURITY UPDATE available
Search API (search_api)                        7.x-1.4            7.x-1.21          SECURITY UPDATE available
Search sorts (search_api_sorts)                7.x-1.3            7.x-1.7           SECURITY UPDATE available
Title (title)                                  7.x-1.0-alpha5     7.x-1.0-alpha9    SECURITY UPDATE available
Views (views)                                  7.x-3.14           7.x-3.16          SECURITY UPDATE available
Views Data Export (views_data_export)          7.x-3.0-beta9      7.x-3.2           SECURITY UPDATE available
Views megarow (views_megarow)                  7.x-1.0            7.x-1.7           SECURITY UPDATE available

Autrement dit il y a du boulot.
Bien sur l'update en drush ne fonctionne absolument pas.
J'obtiens une erreur même lors de la réalisation des backups de module drush:

The date directory could not be found within the modules directory at                                                         [error]
/xxxx/profiles/commerce_kickstart/modules/contrib/date, perhaps the project is enabled but has
been deleted from disk.

J'ai ensuite essayé comme conseillé une mise à jour de commerce_kickstart manuellement en téléchargeant le commerce_kickstart-7.x-2.45 core.
J'ai supprimé sur mon serveur tout les dossiers et fichiers Drupal à l'exception du dossier sites/
Ensuite j'ai copié tous les dossiers et fichiers à l'exception du dossier sites du commerce_kickstart-7.x-2.45 core sur mon serveur.
J'ai essayé d'accéder à l'url update.php et j'obtiens directement un grand nombre de userWarning !

User warning: The following module is missing from the file system: commerce_discount_date. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following module is missing from the file system: commerce_kickstart_payment. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following module is missing from the file system: commerce_kickstart_service_provider. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following module is missing from the file system: jirafe. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following theme has moved within the file system: shiny. In order to fix this, clear caches or put the theme back in its original location. For more information, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following module is missing from the file system: commerce_kickstart_checkout_redirect. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following module is missing from the file system: imagcache_actions. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following theme has moved within the file system: alpha. In order to fix this, clear caches or put the theme back in its original location. For more information, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following theme has moved within the file system: omega. In order to fix this, clear caches or put the theme back in its original location. For more information, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).

J'ai aussi essayer de réinstaller ces modules comme le suggère la documentation => impossible avec drush toujours des erreurs, même pas moyen de faire un clear cache non plus.

J'ai quand même essayé de mettre à jour les 84 pendings updates => ERROR
An AJAX HTTP error occurred. HTTP Result Code: 200 Debugging information follows. update.php?op=selection&token=tLbdNHx9Y0AFjTKaNYc_NuAif0VkT_HPsfb6pIS7f8Q&id=42504&op=do StatusText: OK ResponseText: Fatal error: Call to undefined function inline_conditions_get_info() in /xxx/profiles/commerce_kickstart/modules/contrib/commerce_discount/commerce_discount.rules.inc on line 12

Et voici le contenu de l'error page:
DatabaseSchemaObjectExistsException: Table field_data_commerce_compatibility_strategy already exists. in DatabaseSchema->createTable() (line 660 of /xxx/includes/database/schema.inc).

Ce que j'avais aussi en essayant l'update avec Drush de commerce_kickstart !!!

Quelqu'un aurait une idée car je trouve peu d'information sur Internet ???

Bien à vous.

Forum : 
Version de Drupal :