Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Menu Exploser en plusieur Partie (3 voir 4 )

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour
voila mon petit soucis du moment
Voila mon menu

  • - item 1 => /actus/views1

    • - item 1.1 => /actus/views1

      • - item 1.1.1 => /actus/views1
      • - item 1.1.2 => /actus/page1.1.2
      • - item 1.1.3 => /actus/page1.1.3
    • - item 1.2 => /actus/index2
      • - item 1.2.1 => /actus/index2
      • - item 1.2.2 => /actus/page1.2.2
      • - item 1.2.3 => /actus/page1.2.3
  • - item 2 => /actus/index22
    • - item 2.1 => /actus/index22

      • - item 2.1.1 => /actus/index22
      • - item 2.1.2 => /actus/page223232
      • - item 2.1.3 => /actus/page31321321

Chaque niveau est dans un block diffèrent
J'arrive bien a avoir le premier niveau dans un block
le deuxieme dans un block 2
Le menu du block 2 se mettant bien a jour en fonction du menu de 1 niveau

Mais dans le block 3 rien ca marche jamais

J'obtiens mon premier niveau en affichant mon menu en tant que block.
Le niveau deux viens avec menu_block
le niveau Trois j'ai essayé menu_block mais il ne veux pas afficher le 3eme niveau seul.

Le fait que j'ai un seul lien pour 3 niveau pose t'il soucis ?
n1, n1.1 et n1.1.1 pointe vers la meme page

En fait que je clique sur item1, item1.1, et item1.1.1 ca marche j'arrive a afficher le niveau 3
mais si je clique sur 1.1.2 mon menu de niveau n'est plus la ..
pfff
Comprend pas

[Edit]
En fait je viens de tester avec des nodes differrents a chaque niveau ca marche bien.
mais si dans le cas de la premiere arbo : avec un views ca marche pas
Le probleme viendrais donc d'une page venant d'une views

Merci de votre aide
Kan

Forum : 
Version de Drupal :