Message d'avertissement

The subscription service is currently unavailable. Please try again later.

probleme installation avec ovh sur "copier le fichier default.settings.php en local et le renommer en settings.php."

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

je suis débutant sur drupal et j'ai un problème au niveau du copiage fichier default.settings.php en local et le renommer en settings.php lors de l'installation.

j'arrive a le renommer mais pas a le copier sur la ligne en dessous, c'est grave comme je galère^^

si vous pouvez aussi m'expliquer comment faire l'action
editer le fichier .htaccess : avec FireFTP, clic droit sur le fichier - Open
et Ajoutez la ligne SetEnv REGISTER_GLOBALS 0 à l'avant dernière ligne du fichier.

Quand je fais open il me dirige sur recherche programme a utiliser ou me balance sur
internet ou l'ouvre dans dreapmweaver.je suis perdu a morttttttt
j'arrive pas a editer et encore moins a ajouter une ligne.

si vous pouvez m'aider pour ces 2 actions cela serait cool.
merci d'avance

hyotaboss

Version de Drupal : 

Du calme, du calme.
Déjà on prend les choses calmement. On caresse Drupal dans le sens du poil. Il devient très docile une fois ces premières barrières franchies ;)

Ci-dessous, une copie d'un fichier .htaccess que j'avais configuré pour OVH. Mais attention, il date un peu donc n'écrase pas ton fichier .htaccess, tu en auras besoin si celui-ci pose problème.

Les modif que j'ai apporté :

  • Mettre l'environnement PHP à la version 5;
  • Mettre REGISTER_GLOBALS à 0
  • Autoriser le Rewrite URL (la prochaine grosse galère à laquelle tu aurait été confronté)
  • Considérer les fichier index.* comme des fichier non drupal pour permettre d'installer d'autre page HTML dans le dossier racine si l'installe Drupal est faite dans le répertoire www

Copie dans un nouveau .htaccess à la racine de ton install

Pour ce qui est du fichier settings.php, copie default.settings.php sur ton disque dur, renomme le et glisse le à nouveau dans le répertoire et n'oublie pas de changer les permissions à 777 pendant l'install et revient à 640 quand l'install est finie.

Bonne chance ;)

SetEnv PHP_VER 5

#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.
<FilesMatch ".(engine|inc|info|install|module|profile|test|po|sh|.sql|theme|tpl(.php)?|xtmpl|svn-base)$|^(code-style.pl|Entries.|Repository|Root|Tag|Template|all-wcprops|entries|format)$">
  Order allow,deny
</FilesMatch>

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Make Drupal handle any 404 errors.
ErrorDocument 404 /index.php

# Force simple error message for requests for non-existent favicon.ico.
<Files favicon.ico>
  # There is no end quote below, for compatibility with Apache 1.3.
  ErrorDocument 404 "The requested file favicon.ico was not found.
</Files>

# Set the default handler.
DirectoryIndex index.php

# Override PHP settings. More in sites/default/settings.php
# but the following cannot be changed at runtime.

# PHP 4, Apache 1.
<IfModule mod_php4.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# PHP 4, Apache 2.
<IfModule sapi_apache2.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# Requires mod_expires to be enabled.
<IfModule mod_expires.c>
  # Enable expirations.
  ExpiresActive On

  # Cache all files for 2 weeks after access (A).
  ExpiresDefault A1209600

  # Do not cache dynamically generated pages.
  ExpiresByType text/html A1
</IfModule>

# Various rewrite rules.
<IfModule mod_rewrite.c>
  RewriteEngine on

  # If your site can be accessed both with and without the 'www.' prefix, you
  # can use one of the following settings to redirect users to your preferred
  # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
  #
  # To redirect all users to access the site WITH the 'www.' prefix,
  # (http://example.com/... will be redirected to http://www.example.com/...)
  # adapt and uncomment the following:
  # RewriteCond %{HTTP_HOST} ^example.com$ [NC]
  # RewriteRule ^(.)$ http://www.example.com/$1 [L,R=301]
  #
  # To redirect all users to access the site WITHOUT the 'www.' prefix,
  # (http://www.example.com/... will be redirected to http://example.com/...)
  # uncomment and adapt the following:
  # RewriteCond %{HTTP_HOST} ^www.example.com$ [NC]
  # RewriteRule ^(.
)$ http://example.com/$1 [L,R=301]

  # Modify the RewriteBase if you are using Drupal in a subdirectory or in a
  # VirtualDocumentRoot and the rewrite rules are not working properly.
  # For example if your site is at http://example.com/drupal uncomment and
  # modify the following line:
  # RewriteBase /drupal
  #
  # If your site is running in a VirtualDocumentRoot at http://example.com/,
  # uncomment the following line:
  # RewriteBase /

  # Rewrite URLs of the form 'x' to the form 'index.php?q=x'.
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
</IfModule>

# $Id: .htaccess,v 1.90.2.3 2008/12/10 20:04:08 goba Exp $