Pré-requis

Onglets principaux

La documentation Drupal 6 n'est plus maintenue et en cours de dépublication.

Avant de continuer, Drupal nécessite un certain nombre d'éléments pour pouvoir fonctionner correctement. Ainsi, vous aurez besoin :

  • d'un serveur web
  • PHP 4 (4.3.3 ou plus) ou PHP 5
  • d'une base de donnée MySQL ou PostgreSQL

Note : il est recommandé d'utiliser un serveur web apache avec une base de données MySQL. Toutefois, les autres combinaisons sont possibles mais peuvent être moins testées et ne pas avoir autant de fonctionnalitées (par exemple certains modules additionnels peuvent ne pas être développés pour une base de données PostgreSQL). A cet égard, et pour les débutants, les "packs" :

  • LAMP (Linux, Apache, MySQL, PHP)
  • WAMP (Windows, Apache, MySQL, PHP)

peuvent être un bon support de départ.

Version de Drupal :