Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Accès aux thèmes

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous, j'ai installé Drupal 6.22 parfaitement, tout fonctionne, mais lorsque je vais dans "administrer" je ne trouve pas la rubrique "thèmes", or je voudrai y accéder pour pouvoir choisir la template de mon kit graphique.

En fait, dans la rubrique "site building" je n'ai que les sous-rubriques "blocs' et 'traduction de l'interface". Je vous joins une capture d'écran de ma page administrer.

Si quelqu'un pouvait m'aider, ce serait génial !! :)

A noter que je suis sous Wamp, en localhost

Fichier attachéTaille
Icône image administrer drupal.JPG97.7 Ko
Forum : 
Version de Drupal : 

C'est bon, j'ai trouvé... je suis bête ^^ je n'avais pas importé mon fichier.sql sur phpmyadmin... J'ai enfin réussi mais le problème actuel est que maintenant ce message d'erreur s'affiche :

user warning: Table 'drupal.aggregator_category' doesn't exist query: SELECT COUNT() FROM aggregator_category in C:\wamp\www\drupal\modules\aggregator\aggregator.module on line 273.
user warning: Table 'openid_association' already exists query: CREATE TABLE openid_association ( idp_endpoint_uri VARCHAR(255) DEFAULT NULL, assoc_handle VARCHAR(255) NOT NULL, assoc_type VARCHAR(32) DEFAULT NULL, session_type VARCHAR(32) DEFAULT NULL, mac_key VARCHAR(255) DEFAULT NULL, created INT NOT NULL DEFAULT 0, expires_in INT NOT NULL DEFAULT 0, PRIMARY KEY (assoc_handle) ) /
!40100 DEFAULT CHARACTER SET utf8 / in C:\wamp\www\drupal\includes\database.inc on line 550.
user warning: Table 'openid_nonce' already exists query: CREATE TABLE openid_nonce ( idp_endpoint_uri VARCHAR(255) DEFAULT NULL, nonce VARCHAR(255) DEFAULT NULL, expires INT NOT NULL DEFAULT 0, INDEX nonce (nonce), INDEX expires (expires) ) /
!40100 DEFAULT CHARACTER SET utf8 / in C:\wamp\www\drupal\includes\database.inc on line 550.
user warning: Table 'drupal.aggregator_category' doesn't exist query: SELECT COUNT(
) FROM aggregator_category in C:\wamp\www\drupal\modules\aggregator\aggregator.module on line 273.

C'est grave docteur ? Merci à vous

Bonjour,

Dès lors que tout n'apparait pas, je ne dirais pas comme vous que vous avez installé Drupal parfaitement et que tout fonctionne. Je vous conseille donc de refaire une installation.

Supprimez tous les champs dans la base que vous avez créée (via phpmyadmin) et relancez l'installation localhost/mon_repertoire/install.php

Merci de vous être arrêté sur mon problème ^^ comme je l'ai dit, j'ai résolu mon problème d'affichage, cependant plusieurs messages d'erreurs ont fait leur apparition. C'est eux que je voudrai résoudre car maintenant, j'ai bien accès à la template que j'ai téléchargé.

Vous avez manifestement restauré dans votre base une sauvegarde sql qui semble ne pas faire bon ménage avec votre installation locale tout en ayant partiellement résolu votre problème d'affichage. Oui ?

J'ai acheté un kit graphique avec à l’intérieur une sauvegarde sql, représentant mon site web à proprement dit, donc je pense que vous avez raison car le problème est arrivé après avoir importer cette sauvegarde, mais sinon, j'ai accès à tout mon site, sauf que le message me suit à chaque page.

Votre module aggregator est-il activé ?

Avez-vous vidé vos caches ?

Vous pouvez éventuellement lancer un update.php car votre "kit graphique" a peut-être mis à jour des modules sans effectuer une actualisation correcte de la BDD.

Voici le message d'erreur que j'ai depuis aggregator de Drupal
:
Feed Aggregator
user warning: Table 'drupal.aggregator_category' doesn't exist query: SELECT COUNT() FROM aggregator_category in C:\wamp\www\drupal\modules\aggregator\aggregator.module on line 273.
user warning: Table 'drupal.aggregator_item' doesn't exist query: SELECT COUNT(
) FROM aggregator_item i INNER JOIN aggregator_feed f ON i.fid = f.fid in C:\wamp\www\drupal\modules\aggregator\aggregator.pages.inc on line 86.
user warning: Table 'drupal.aggregator_item' doesn't exist query: SELECT i.*, f.title AS ftitle, f.link AS flink FROM aggregator_item i INNER JOIN aggregator_feed f ON i.fid = f.fid ORDER BY i.timestamp DESC, i.iid DESC LIMIT 0, 20 in C:\wamp\www\drupal\modules\aggregator\aggregator.pages.inc on line 86.
user warning: Table 'drupal.aggregator_category' doesn't exist query: SELECT COUNT(*) FROM aggregator_category in C:\wamp\www\drupal\modules\aggregator\aggregator.module on line 273.

La ligne correspondante est celle-ci :
/
function _aggregator_has_categories() {
return user_access('access news feeds') && db_result(db_query('SELECT COUNT(
) FROM {aggregator_category}'));
}