Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Simplenews/Mime type et serveur SMTP sécurisé

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Salut tout le monde,

je rencontre un petit souci avec le couple de module Simplenews/Mime type.

En effet, le serveur SMTP de mon FAI est un serveur sécurisé avec authentification. Il n'est donc pas possible (sauf si je me trompe), de paramétrer cela dans le php.ini de mon serveur.
Pour l'utilisation seule de Simplenews, j'ai réussi à me débrouiller en utilisant PEAR, et en modifiant le fichier mail.inc.

Cependant, j'ai depuis rajouté le module Mime type pour envoyer des mails au format HTML, et là, quand j'ai voulu tester, ça a à nouveau planté, comme avant que je fasse les modifs dans mail.inc.

J'ai regardé dans le fichier mimemail.module, là où ça me dit que ça plante, mais ça m'a l'air un poil plus compliqué.

J'aimerai donc savoir s'il y a moyen de configuré dans Drupal un serveur SMTP avec authentification sans avoir à tout modifier dans les fichiers correspondant aux modules Simplenews et Mime type ???

Merci d'avance pour vos réponses.

Tchuss, @+, jinpol...

Je viens de trouver un module : SMTP Authentication Support qui permet de paramétrer un serveur SMTP sécurisé.
J'ai installé PHPMailer comme demandé, j'ai paramétré le module, et il permet d'effectuer un test quand on valide le paramétrage.
J'ai bien reçu le mail de test...

Cependant, quand je fais une nouvelle Newsletter, ça ne marche pas, car il prend ce que j'ai dans mon php.ini, et donc ça plante comme précédemment.

Ma question est donc maintenant, une fois que le module SMTP Authentication Support est activé, comme fait on pour l'utiliser par défaut lors de l'envoi de mails par Drupal ???

Merci d'avance pour vos réponses.
Tchuss, @+, jinpol...

Bon je continue de me répondre pour dire où j'en suis en attendant j'espère que quelqu'un puisse m'aider à résoudre mon problème.

En fait, j'ai fait une série de test, et par exemple, quand je m'abonne à une Newsletter que j'ai crée, j'ai bien un mail qui est envoyé à l'adresse entrée par l'utilisateur via le module SMTP Authentication Support, car quand je le désactive, j'ai un message d'erreur lors de l'envoi du mail.

Il reste donc juste à savoir comment on fait pour utiliser ce module pour envoyer les Newsletter, plutôt que d'utiliser les paramètres présents dans php.ini.

Merci d'avance.
Tchuss, @+, jinpol...

Personne ici n'utilise Simplenews avec un serveur SMTP sécurisé ???
Si quelqu'un a ma réponse, pitié, qu'il se manifeste :)

Je dois vraiment régler ce problème pour pouvoir utiliser Drupal. Ca serait dommage de tout laisser tomber juste pour un problème d'envoi de mail...

Merci d'avance.
Tchuss, @+, jinpol...

Salut Jinpol,

As-tu bien placé le dossier du module décompressé "PHPmailer" à la racine du dossier du module décompressé de "SMTP Authentification Support" comme expliqué dans le dernier post ici ? :

http://drupal.org/node/202879

Cordialement,

Thib'

Salut et merci pour ta réponse.

J'ai bien mis le dossier PHPMailer à la racine de SMTP.
Et ce qui est bizarre, c'est que parfois la Newsletter en HTML, arrive (et donc, c'est bien SMTP Authentication qui est utilisé), et parfois, ça plante, et là, c'est les params de php.ini qui sont utilisés.

J'ai fait bcp de recherches sur le net, et je n'ai pas trouvé de solutions. donc si quelqu'un a déjà rencontrer ce problème, leur aide sera le bienvenue.

Merci d'avance.
Tchuss, @+, jinpol

Salut,

J'ai exactement le même souci que toi.Quand je créé un user et que je veux envoyer cette inscription par mail,ça plante,il me dit que le problème vient de php.ini.
Pour tant lors du test du module de smtp, je reçois bien un mail.

Une fois que le module SMTP Authentication Support est activé, comment fait-on pour l'utiliser par défaut lors de l'envoi des mails par Drupal ?

As-tu trouvé une réponse à ta demande???

Merci
Nico

Bonjour à tous,

Je ne sais pas si ça peut éventuellement vous aider.
J'ai installer le module PHPMailer en suivant la doc et tout fonctionne très bien.
Donc si vous avez besoins d'infos...
Cordialement,

Thibaut

Bonjour pydubreucq,

Alors j'ai juste installé le module SMTP Authentication Support.Et j'ai ensuite suivi la procédure d'installation.

J'ai télécharger le package PHPMailer-ML_v1.8.1_core.zip.Dedans je suis allé dans le répertoire PHPMailer-ML_v1.8.1_core_acp-ml\modules\ et j'ai copié le dossier Phpmailer dans le répertoire /sites/all/modules/smtp/

J'ai rien touché au dossier PhpMailer.Quand je test le module je reçois bien le mail,par contre dès que je passe par l'enregistrement d'un nouvelle utilisateur et que je veux le notifier.ça plante et ça me dis que je dois configurer le php.ini.
Est-ce fait une erreur ou pas ?

Merci d'avance

Bonne fin de journée

Bien le bonjour,
Je ne sais pas trop...
Tu peux toujours paramétrer la variable sendmail dans ton php.ini
sendmail_path = /usr/sbin/sendmail
Si tu utilises Qmail, ça sera peut-être :
sendmail_path = /var/qmail/bin/sendmail
Tu peux tester ça et nous dire quoi ;) - pour les Chti
Tu peux tester ça et nous dire ce qu'il en est ;) - pour les autres ;)
Bonne journée

Bonjour

C'est bien le php.ini présent dans le dossier apache? -> Juste une confirmation
Le chemin du sendmail_path point sur un dossier que je suis sensé trouvé ou?
/usr/sbin/sendmail -> J'ai cherché dans le dossier Xampp et j'ai pas trouvé!!!

Merci en tout cas pour ton aide

Bonne journée

Bonjour,

Ce post est un peu vieux, mais j'ai peut être trouvé la solution (si ca peut servir à quelqu'un) : dans la page de configuration de mime mail, il est possible de choisir le serveur smtp sortant !

Cordialement,
Benoit