Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Installation de Drupal et PHP 5.3

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

Je viens d'installer la dernière version de WampServer (2i) en local. Cette livraison contient la toute nouvelle version 5.3 de PHP.
En voulant installer Drupal en local, je me suis heurté à une kyrielle de message "Deprecated".
En me documentant sur PHP 5.3, j'ai découvert qu'il introduit un nouveau niveau d'erreur : "Deprecated".
Il s'agit de messages signalant l'utilisation de directives INI ou de fonctions obsolètes.

Voici la liste des directives INI et fonctions obsolètes sous PHP 5.3 :
define_syslog_variables ;
register_globals ;
register_long_arrays ;
safe_mode ;
magic_quotes_gpc ;
magic_quotes_runtime ;
magic_quotes_sybase ;
call_user_method() ;
call_user_method_array() ;
define_syslog_variables() ;
dl() ;
ereg() ;
ereg_replace() ;
eregi() ;
eregi_replace() ;
session_register() ;
session_unregister() ;
session_is_registered() ;
set_socket_blocking() ;
split() ;
spliti() ;
sql_regcase() ;
mysql_db_query() ;
mysql_escape_string() ;

set_magic_quotes_runtime() et ses alias magic_quotes_runtime() ;

L'utilisation des chaînes pour les catégories de locales est maintenant obsolète ;
Le paramètre is_dst de mktime() ;

Quelqu'un a-t-il une idée sur la marche à suivre ???
Faut-il attendre une version de Drupal qui règle ce problème ?, dois-je tout simplement ré-installer une version antérieure de PHP ?, ou dois-je essayer de désactiver ces messages d'avertissement sur PHP 5.3 (si la chose est possible !!!) ?

Bonne fin de journée,
Didier.

Version de Drupal : 

Aux dernières nouvelles (pour tous les détails, voir http://drupal.org/node/360605):

  • Drupal 6.13 ne supporte pas (encore) PHP 5.3
  • Drupal 6.14 devrait supporter PHP 5.3. Vu qu'il n'est pas possible de garantir une compatibilité complète (au sens de E_DEPRECATED) sans modifier l'API (notamment du fait de l'usage de ereg_* dans certaines fonctions de Drupal 6), Drupal 6.14 cachera les erreurs E_DEPRECATED.

Bonjour,

En attendant que Drupal devienne compatible avec la version 5.3 de PHP, les utilisateurs de WampServer peuvent télécharger la version 5.2.9-2 de PHP sur la page suivante : http://www.wampserver.com/addons_php.php.
Si vous avez installé WampServer 2.0i [11/07/09] qui contient Apache 2.2.11, MySQL 5.1.36 et PHP 5.3.0, il suffit d'installer le "addons" de la même manière que vous avez installé WampServer.
Dès lors, votre WampServer contiendra, à la fois, les versions 5.3.0 et 5.2.9.
Pour changer de version de PHP, il suffit de lancer WampServer. Dans le menu "PHP", vous trouverez un sous-menu "Version" dans lequel vous pourrez sélectionner celle de votre choix.
En un mot, WampServer permet d'installer plusieurs version de PHP en local.

Bon amusement et bonne journée,
Didier.

Bonjour.

Même chose que saradimi : il y a un problème à l'installation de Drupal 6.14 avec WampServer 2.0 (et PHP 5.3.0).
Toujours ce message :
Deprecated: Function ereg() is deprecated in C:\wamp\www\includes\file.inc on line

(line = 912 ou 895, selon les bidouillages de réinstallation)

Juste une question : ne serait-ce pas dû au module de traduction fr ? (je pose juste la question :-) )

Salut.

Je remets le passage :

" Pour ton problème d'erreur en boucle il faut que tu télécharge la version PHP antérieure à la version 5.3 ici (ça devrait être la 5.2.11) :
www.wampserver.com/addons_php.php "

Rien à faire, je n'arrive pas à installer cette version WampServer2-PHP5211
(depuis hier soir aussi).

J'ai un "unable to execute file : c:\wamp\wampmanager.exe"
Et en effet je n'ai pas de wampmanager.exe ...

As-tu bien la version Wampserver 2.0i avec Apache 2.2.11 et MySQL 5.1.36 ?

L'ensemble de tes fichiers drupal ont ils été décompressé dans un fichier comme ça /wamp/www/mon_site ?
(d'après le message d'erreur le fichier includes semble être directement dans le fichier www...)

Bonjour,

J'ai essayé d'installer Drupal 6.14 avec WampServer 2.0i et il existe toujours des erreurs "Deprecated" lorsqu'on choisi le PHP 5.3.0

Par contre, aucun problème lorsqu'on installe le PHP 5.2.11

Donc, le mieux serait de télécharger le "addons" du PHP 5.2.11 à l'adresse suivante : http://www.wampserver.com/addons_php.php

Bonne soirée,
Didier.

moi j'ai bien installer php 5.2.11 mais j'ai un autre problème

Database configuration
The following installation warning should be carefully reviewed:
Operations on Unicode strings are emulated on a best-effort basis. Install the PHP mbstring extension for improved Unicode support. (Currently using Unicode library Standard PHP)
Your web server does not appear to support any common database types. Check with your hosting provider to see if they offer any databases that Drupal supports.

Bonjour à vous.

Le fichier WampServer2+ PHP 5210 est bien présenté comme "add-on" ? Par conséquent il ne faut pas désinstaller auparavant WampServer2.0i, sommes-nous d'accord ? :)

Autre question : entre-temps j'ai installé la base joomla (je souhaitais tester les 2 CMS : drupal et joomla).
- Est-ce que je peux installer un nouveau répertoire en local, à la base de c:\wamp\www et surtout :
- Comment faire pour basculer d'un site à l'autre (et donc d'un système à l'autre), toujours en local ?

Merci :)

Bonjour,

D'abord, pour répondre à la première question, il faut installer WampServer 2.0i (http://www.wampserver.com/download.php) avant d'installer l'un des "add-ons" proposé sur le site de "WampServer" (http://www.wampserver.com/add-ons.php).

Ensuite, lorsque "WampServer" est installé, ne pas oublier d'activer l'option "rewrite_module". Une fois activé, il permet d'utiliser les Url Simplifiées.
Pour activer cette option : lancer "WampServer", clic gauche sur la petite icône WampServer en bas à droite (dans la zone de notification), sélectionner "Apache", ensuite "Modules Apache", descendre la liste jusqu'à "rewrite_module", cliquer sur cette option pour l'activer et, enfin, attendre quelques secondes pour que "WampServer" enregistre la modification.

Pour installer "Joomla!" en même temps que "Drupal" ce n'est pas très compliqué. Il suffit simplement de créer deux sous-répertoires dans "c:\wamp\www\".

Par exemple, vous créez un premier répertoire appelé "joomla" ("c:\wamp\www\joomla\") dans lequel vous décompressez le package "Joomla!". Attention, la version 1.5.15 de "Joomla!" n'est pas compatible avec le PHP 5.3 et donc il faudra aussi utiliser "WampServer" avec le "add-on" PHP 5.2.11 (ou 5.2.10, c'est égal !).
Avant l'installation de "Joomla!" en local, n'oubliez pas de créer une base de données avec phpMyAdmin. Vous pourriez l'appeler "joomla".
Ensuite, vous créez un second dossier appelé "drupal" ("c:\wamp\www\drupal\") et vous procédez de la même manière qu'avec "Joomla!". Vous devez créer une autre base de données (par exemple: "drupal").

Pour accéder, en local, à l'un ou l'autre de ces deux sites, il existe deux méthodes.
La première: une fois "WampServer" lancé, il suffit de faire un clic gauche sur l'icône en zone de notification et d'exécuter "Localhost". Cette action lance votre navigateur. Celui-ci charge le fichier "index.php" que "WampServer" à installé dans le répertoire "c:\wamp\www\" (si vous avez supprimé ce fichier, il suffit de désinstaller et de réinstaller "WampServer"). Ce fichier "index.php" est utile pour circuler dans les répertoires que vous avez créés.
La seconde: vous pouvez utiliser l'adresse "http://localhost/joomla/" pour accéder au site installé dans le dossier "c:\wamp\www\joomla\" ou "http://localhost/drupal/" pour le site placé dans le répertoire "c:\wamp\www\drupal\".

Un dernier mot: vous pourriez créé plusieurs sites avec "joomla!" ou/et avec "drupal". Il suffit de créer autant de dossiers et autant de base de données que vous le souhaitez. Il est également possible de créer un site dans un sous-répertoire d'un sous-répertoire (exemple: "c:\wamp\www\joomla\premiersite\" ou "c:\wamp\www\drupal\monsite\").

Voilà, j'espère avoir répondu à la question.

Bonne fin de journée,
Didier.